The Joystick Orchestra Game requires Flash version 10.3 or heigher.

Get Adobe Flash player